Securing site with https - certain pages will fail because of Mixed Content

Hello, I secured my site so that it requires access via https instead of http. However, not the logi...

Terrence

Monday, 21 March 2016

Terrence

Hello, I secured my site so that it requires access via https instead of http. However, not the login ad rotator ( https://revshareworks.com/members/ads/loginads_rotator ) does not show the offsite content because all browsers by default will not display content served over http if the main page was served with https. The specific error message is:

Blocked loading mixed active content "http://..."

While I am not using it, the same issue will occur with the traffic exchange / site surfing feature.

Unfortunately, it appears that the entire site can only be configured for one or the other in includes/config.inc.php using the constant SITEURL

So: how do we configure the revshare script so that the loginad_rotator and traffic exchange are http links but the rest of the site uses https links?

Post new message in forum

Post new message in forum

2gosoft Solutions

Friday, 15 April 2016

2gosoft Solutions

Simply access pages where you want to display members ads with http to get around this.

Post new message in forum

Post new message in forum

Shaun

Tuesday, 31 October 2017

Shaun

Please be spesific, I noticed that the issue is with your 2gosoft.com pointing in the banner section :

Mixed Content: The page at 'https://myawesomehub.com/' was loaded over HTTPS, but requested an insecure image 'http://2gosoft.com/banners/125.gif'. This content should also be served over HTTPS.

How do I remove the banner code and where, please advise.

Post new message in forum

Post new message in forum

Topic information

Forum 2gosoft Adshare
Topic Securing site with https - certain pages will fail because of Mixed Content
Started By Terrence
Views 927
Messages 3
Since Monday, 21 March 2016

Back to threads list